Tuesday, February 7, 2023
HomeNetworkingWhat's eBGP Multihop In BGP?

What’s eBGP Multihop In BGP?


Whereas configuring BGP neighbours, Loopback interface is the popular supply for forming BGP neighborship. The reason is the Loopback supply doesn’t ever go down even when the bodily interface is down.

Extra so, Loopback turns into extra necessary when we now have 2 or extra interfaces connecting BGP neighbours and actually, Load balancing of visitors may also be achieved. One key consideration whereas configuring eBGP neighborship on Loopback interfaces is to set the TTL to 2 for immediately related routers to have the ability to peer between their loopbacks as a result of the TTL will get decremented on the way in which to the loopback. The multihop BGP is just for eBGP and never for iBGP.

Associated – EBGP VS IBGP

Pattern situation :“eBGP Multihop

Under given situation will give you the higher understanding of eBGP Multihop:

Within the given situation, we now have 3 Routers R1, R2 and R3 related in sequence. Whereas R1 and R2 are immediately related and in BGP AS 1 , Router R3 belongs to AS 3.

Associated – BGP Native Choice Attribute

R1 and R2 will type iBGP neighborship whereas R2 and R3 ought to type eBGP neighborship. All of the BGP neighborship (iBGP and eBGP) must be shaped by way of Loopback 0 of every Router.

R1, R2 and R3 configuration is given beneath –

R1#
interface Loopback0 ip handle 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip handle 192.168.12.1 255.255.255.0
!
router bgp 1
no synchronization
bgp log-neighbor-changes
community 192.168.12.0
neighbor 2.2.2.2 remote-as 1
neighbor 2.2.2.2 update-source Loopback0  ——–>R1 to make use of Loopback 0 as supply for BGP neighborship and updates   
no auto-summary
!
ip route 2.2.2.0 255.255.255.0 192.168.12.2 ——->Static Route to succeed in Loopback0 of R2

 

R2#sh run
!
interface Loopback0
ip handle 2.2.2.2 255.255.255.0
!
interface FastEthernet0/0
ip handle 192.168.12.2 255.255.255.0
!
interface FastEthernet0/1
ip handle 192.168.23.2 255.255.255.0
!
router bgp 1
no synchronization
community 192.168.12.0
community 192.168.23.0
neighbour 1.1.1.1 remote-as 1
neighbour 1.1.1.1 update-source Loopback0 ——–>R2 to make use of Loopback 0 as a supply for BGP neighborship and updates with R1
neighbor 1.1.1.1 next-hop-self
neighbour 3.3.3.3 remote-as 3
neighbor 3.3.3.3 update-source Loopback0——–>R2 to make use of Loopback 0 as a supply for BGP neighborship and updates with R3
no auto-summary
!
ip route 1.1.1.0 255.255.255.0 192.168.12.1 ——->Static Route to succeed in Loopback0 of R1
ip route 3.3.3.0 255.255.255.0 192.168.23.3 ——->Static Route to succeed in Loopback0 of R3

 

R3#sh run
!
interface Loopback0
ip handle 3.3.3.3 255.255.255.0
!
interface FastEthernet0/1
ip handle 192.168.23.3 255.255.255.0
!
router bgp 3
no synchronization
community 192.168.23.0
neighbor 2.2.2.2 remote-as 1
neighbor 2.2.2.2 update-source Loopback0——–>R3 to make use of Loopback 0 as a supply for BGP neighborship and updates with R2
no auto-summary
!
ip route 2.2.2.0 255.255.255.0 192.168.23.2——->Static Route to succeed in Loopback0 of R2

Now , lets see the BGP neighborship throughout 3 Routers

R1#sh ip bgp abstract
BGP router identifier 1.1.1.1, native AS #1
BGP desk model is 12, important routing desk model 12
2 community entries utilizing 234 bytes of reminiscence
3 path entries utilizing 156 bytes of reminiscence
3/2 BGP path/bestpath attribute entries utilizing 372 bytes of reminiscence
0 BGP route-map cache entries utilizing 0 bytes of reminiscence
0 BGP filter-list cache entries utilizing 0 bytes of reminiscence
BGP utilizing 762 whole bytes of reminiscence
BGP exercise 5/3 prefixes, 7/4 paths, scan interval 60 secsNeighbor    V    AS    MsgRcvd      MsgSent   TblVer  InQ OutQ        Up/Down  State/PfxRcd
2.2.2.2         4     1     100                    99                12          0           0             01:33:00        2

R1 and R2 are forming iBGP neighborship and receiving routes by way of BGP.

R2#sh ip bgp abstract
BGP router identifier 2.2.2.2, native AS #1
BGP desk model is 16, important routing desk model 16
2 community entries utilizing 234 bytes of reminiscence
3 path entries utilizing 156 bytes of reminiscence
3/1 BGP path/bestpath attribute entries utilizing 372 bytes of reminiscence
0 BGP route-map cache entries utilizing 0 bytes of reminiscence
0 BGP filter-list cache entries utilizing 0 bytes of reminiscence
BGP utilizing 762 whole bytes of reminiscence
BGP exercise 5/3 prefixes, 8/5 paths, scan interval 60 secs
Neighbor    V    AS  MsgRcvd        MsgSent              TblVer  InQ         OutQ     Up/Down  State/PfxRcd
1.1.1.1         4       1     100                  101                         16           0              0              01:33:55               1
3.3.3.3         4     3      70                     70                        0             0              0              00:13:16               Idle

R2 is forming iBGP neighborship with R1 whereas R2 eBGP neighborship with R3 remains to be down ie in “init” state

Additionally, lets see the “present ip bgp abstract” output on R3 –

R3#sh ip bgp abstract
BGP router identifier 3.3.3.3, native AS quantity 3
BGP desk model is 2, important routing desk model 2
1 community entries utilizing 117 bytes of reminiscence
1 path entries utilizing 52 bytes of reminiscence
2/1 BGP path/bestpath attribute entries utilizing 248 bytes of reminiscence
0 BGP route-map cache entries utilizing 0 bytes of reminiscence
0 BGP filter-list cache entries utilizing 0 bytes of reminiscence
BGP utilizing 417 whole bytes of reminiscence
BGP exercise 3/2 prefixes, 4/3 paths, scan interval 60 secs
Neighbor    V    AS    MsgRcvd      MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4     1      70                     70               0              0          0      00:15:12       Idle

From the output , we see that R1 and R2 type iBGP neighborship whereas R2 and R3 don’t type eBGP neighborship. The configuration on 3 Routers has adopted the identical strategy , nonetheless iBGP neighbors have shaped peering whereas eBGP multihop Routers haven’t. Now , lets introduce “ebgp-multihop 2”  command between R2 and R3 and discover out what occurs –

R2(config)#router bgp 1
R2(config-router)#neighb 3.3.3.3 ebgp-multihop 2
R3(config)#router bgp 3
R3(config-router)#neighbor 2.2.2.2 ebgp-multihop 2

After issuing “ebgp-multihop 2” on each R2 and R3 Routers , BGP neighborship is seen on each as beneath –

R2(config-router)#do sh ip bgp summ
BGP router identifier 2.2.2.2, native AS #1
BGP desk model is 16, important routing desk model 16
2 community entries utilizing 234 bytes of reminiscence
4 path entries utilizing 208 bytes of reminiscence
4/1 BGP path/bestpath attribute entries utilizing 496 bytes of reminiscence
1 BGP AS-PATH entries utilizing 24 bytes of reminiscence
0 BGP route-map cache entries utilizing 0 bytes of reminiscence
0 BGP filter-list cache entries utilizing 0 bytes of reminiscence
BGP utilizing 962 whole bytes of reminiscence
BGP exercise 5/3 prefixes, 9/5 paths, scan interval 60 secs
Neighbor        V    AS MsgRcvd     MsgSent   TblVer  InQ OutQ        Up/Down  State/PfxRcd
1.1.1.1         4     1     108                    109             16           0       0                01:41:31        1
3.3.3.3         4     3      76                      76               16          0       0                00:01:19        1

R3#sh ip bgp abstract
BGP router identifier 3.3.3.3, native AS quantity 3
BGP desk model is 3, important routing desk model 3
2 community entries utilizing 234 bytes of reminiscence
3 path entries utilizing 156 bytes of reminiscence
3/2 BGP path/bestpath attribute entries utilizing 372 bytes of reminiscence
1 BGP AS-PATH entries utilizing 24 bytes of reminiscence
0 BGP route-map cache entries utilizing 0 bytes of reminiscence
0 BGP filter-list cache entries utilizing 0 bytes of reminiscence
BGP utilizing 786 whole bytes of reminiscence
BGP exercise 4/2 prefixes, 6/3 paths, scan interval 60 secsNeighbor   V    AS    MsgRcvd       MsgSent   TblVer  InQ OutQ        Up/Down  State/PfxRcd
2.2.2.2        4     1                 75           75               3              0          0              00:00:03         2

Therefore, we deduce that after issuing “ebgp-multihop” command between ebgp neighbors , neighborship is shaped over Loopback interfaces. That is required since eBGP makes use of a default worth of 1 ie solely immediately related interfaces to type neighborship. To be able to attain Loopback of immediately related Routers, TTL worth must be incremented to 2 in eBGP utilizing “ebgp-multihop 2” command.

 

RELATED ARTICLES

LEAVE A REPLY

Please enter your comment!
Please enter your name here

- Advertisment -
Google search engine

Most Popular

Recent Comments